Over the coming months, we’ll be converting our integrations to use the Singer open source project. Powering the Stitch platform with Singer means that there are no limits to the types of data sources that Stitch can integrate with, and since the code is open source, users have complete visibility into and control of how their data is collected.

Check out the Singer organization on GitHub.


Upgrade Your Integrations

To upgrade to the latest version of an integration, you’ll need to do the following:

  1. Re-create all affected integrations in your account. New connections will use the latest version of the integration. See the next section for deprecation info for affected integrations.

    Note that:

    • Historical data will need to be re-synced for new connections. You can do this during setup by changing the integration’s start date.

    • Row usage for the newly created integrations will be exempt for two weeks so that you may re-sync historical data free of charge. Note that it may take up to one business day for this to take effect.

  2. Delete the old versions of the integration from your account.

If you need a refresher on setting up an integration, refer to the SaaS Integration docs.


Version Deprecation Dates

Below is a list of integration versions currently scheduled for deprecation. These versions will continue to run after their deprecation date, however, they will no longer receive support.

As we prepare to convert integrations, we’ll add them to this list. We’ll also announce updates on our status page, which you can subscribe to.

Integration Version Deprecation Date Link to latest version
HubSpot prior to 1.0 November 22, 2017 See the code here.

More Info & Support

If you have questions about these changes, reach out to support - we’ll be happy to help!

To stay up-to-date on the latest and be notified of upcoming integration releases, subscribe to our changelog and status page.